FCL - Authenticate with dev wallet

Hello there !

I followed the quickstart to launch a web app with Flow here :

The only thing I did differently was to start the blockchain from another folder which contains the Marketplace tutorial code. (which seemed to be a good idea, as in the real world you might connect your app to existing smart contracts)

However I ran in this error :
unknown method GetAccountAtLatestBlock for service access.AccessAPI

I found a reference here : Discord where it is said that we need to update the emulator, but my emulator should be up to date (v0.4.1).
Since the wallet needs a flow.json file, I added the chains service account after doing flow init

Lastly, I have also tried with following exactly the tutorial from the beginning without any success.
I also tried running with the VS extension or not, but without any success.

I don’t really know where the issue can come from. :confused:

I am going to follow exactly Max’s presentation to see if it works better.
EDIT : after following Max’s youtube video (I just did not use docker), I still have the same issue.

But I would appreciate any information
NB: I also tried doing an angular app but the fcl package seems to be creating issues with the http module. Any information on that ?

As I’ve mentioned on Discord, try to update emulator and libraries to latest version :slight_smile:

Thank you Max !

But I don’t know if it is related, but it seems that my VSCode extension does not work anymore. :frowning:
I can’t deploy contracts because of a syntax error that I can’t fix :

I tried uninstalling and reinstalling the vscode extension but it does not seem to work. (I am in version 0.4.0)

Thanks @MaxStarka for the solution.

If you ever come accross the error :
unrecognized character: U+000D

Try this change :

  • Click in the bottom right of the corner on CRLF
  • Change it to LF
  • All is well !

1 Like

Worked for me as well.Thanks

1 Like