Decode private key failed error when using emulator

flow.json contains invalid json: decode private key failed: the signature scheme UNKNOWN is not supported.

Stuck with this error whenever I try and send a transaction with the Flow CLI. The error is definitely with my flow.json, since just writing “flow transactions send” with no parameters results in this error. My account in flow.json looks like this
“accounts”: {
“service”: {
“address”: “f8d6e0586b0a20c7”,
“keys”: “1748ed39625b4d2dd2716be884dadd50ac82877b888ed5ecf19412d7644fl791”,
“chain”: “flow-emulator”
I’ve tried basically every way of formatting flow.json to no avail. I think it’s a bug, since I get the same error if I try to use the emulator with “flow emulator start”, however have no issues with “flow project start-emulator”. I’m able to get my transactions to work in the Flow playground as well. Anyone else experienced this or understand why this is happening?

Hi @CoachGibbo I can help you with that.

Currently there are two concepts in CLI: 1. project commands with associated config you have (they are used to deploy and start-emulator) 2. other commands which require config you can create by running flow init.

For your scenario I suggest you make a separate config with flow init and then run flow transactions send in the folder with that config.

I know this is not great and new version with unified configuration is already on its way, so bear with us and I’m sorry for the inconvenience. You can tag me if you will have anymore questions or problems with CLI. If you have any feedback beside the obvious to unify this config let me know :slight_smile: