Unable to go get flow-go-sdk

Hi, tried to install flow-go-sdk on ubuntu using go get -u github.com/onflow/flow-go-sdk but i’m getting an error “go/src/github.com/onflow/cadence/runtime/interpreter/decode.go:43:18: undefined: cbor.StreamDecoder”. How can i go about solving this issue?

@sideninja Any idea what is happening here?

I tried the same installation on my host machine which is on Windows and its fine. Not sure if it’s a problem with my VM or the ubuntu environment.

Might be an issue with your workspace/GOPATH? Maybe try command with flags go get -u -v -f all

1 Like

Did anyone solve the problem ? How to solve it ? I meet the same error on Windows.

I have opened https://github.com/onflow/flow-go-sdk/pull/197 to fix this

Similar issue happened to me. go/src/github.com/onflow/atree/encode.go:44:11: undefined: cbor.StreamDecoder. I think this is due to this package github.com/fxamacker/cbor/v2 not able to be found. I tried to go get this package separately of running get flow-go-sdk, but still not working.

I am using go version 1.16 on Macbook pro m1.