Newbie stuck on the tutorials - creating faucet and signing transactions on emulator

Hey Flow community! I’m a newbie, learning about flow.

I’m trying to play with the sample contracts and running in all kinds of issues.

  1. I’m unable to create an account on testnet. For real, I’m stuck on the simplest step.

I created a key-pair using cli (I tried defaults as well as different signiture algos), I paste my public key to , solve captcha, it thinks for a while and gives me a generic ’ Account creation has failed. Check Network Status’. As you probably have guessed - network is healthy.
Could someone give me steps for a complete idiot I am?

  1. I tried to use emulator but I can’t figure out how to sign the transactions by an account that was created using emulator and is not in the configuration. flow transactions sign … --signer expects an alias and I don’t have an alias. How can I do it?

Also is there any stack exchange or a better place for these kind of questions?

Thanks for your help!

Point 1 got automagically solved - I am able to create a testnet account, using the same public key as was failing before.
Second questions is still valid.

hiya @p1xelch1ck!

for point #2, an alias represents the account defined in the configuration (flow.json). Have you added the account you created via the emulator into your flow.json?

FYI - Default for signer is emulator-account.

Let me know if this resolves your problem. We have a great developer community on our discord - would love for you to join us there if you haven’t where you can also ask your questions in the #developers channel :slight_smile:

Thanks @kimcodeashian !